HDOJ 1063 HDU 1063 Exponentiation JAVA 编写 ACM 1063 IN HDU
时间:2010-09-10 来源:MiYu
MiYu原创, 转帖请注明 : 转载自 ______________白白の屋
题目地址: http://acm.hdu.edu.cn/showproblem.php?pid=1063
题目描述:
Exponentiation
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1696 Accepted Submission(s): 376
Problem Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
这两天突然想学习下JAVA 的大数 就学习了一下, 这道题在PKU A掉了的, 不过在 HDU 一直没过, 不知道有什么恶心的数据把我给恶心掉了, 很郁闷.
不过 用JAVA直接 1 A 了........... 很简单的说
代码如下 :
/*
* To change this template, choose Tools | Templates
* and open the template in the editor.
*/
import java.util.Scanner;
import java.math.*;
/**
*
* @author baiyun
*/
public class Main {
/**
* @param args the command line arguments
*/
public static void main(String[] args) {
Scanner in = new Scanner ( System.in );
BigDecimal num;
int exp;
while ( in.hasNext() ){
num = in.nextBigDecimal();
exp = in.nextInt();
num = num.pow ( exp );
num = num.stripTrailingZeros();
String out = num.toPlainString();
if ( out.charAt(0) == '0' )
out = out.substring(1);
System.out.println( out );
}
}
}