文章详情

  • 游戏榜单
  • 软件榜单
关闭导航
热搜榜
热门下载
热门标签
php爱好者> php文档>HDU 3351解体报告

HDU 3351解体报告

时间:2010-05-27  来源:zackchen

http://acm.hdu.edu.cn/showproblem.php?pid=3351

Problem Description

I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.


Input

Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)


Output

For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.

Sample Input

}{
{}{}{}
{{{}
---


Sample Output

1. 2
2. 0
3. 1

Source
2009 ANARC

   其实这道题就是运用栈的思想来做,扫描整个字符串后,去掉所有匹配的括号,剩下不能匹配的就是 }}}{{{ 这样的形式,使用两个int变量记录不匹配的{和}的个数,如果x和y是偶数,那将}和{各翻转一半,如果是奇数就将中间单独的一对 }{ 单独处理,即ans=x/2+y/2+x%2+y%2;

CODE

#include<stdio.h>
#include<string.h>

int main()
{
  int count=0,x,y,i,j,len,ans;
  char s[2005];
  while(scanf("%s",s)!=EOF,s[0]!='-')
    {
      x=y=0;
      for(i=0;s[i];i++)
    {
     if(s[i]=='{')x++;
     else
     {
     if(x>0)x--;
     else y++;
     }
    }
      ans=0;
      ans+=x/2+y/2+x%2+y%2;
      printf("%d. %d\n",++count,ans);
    }
  return 0;
}


相关阅读 更多 +
排行榜 更多 +
辰域智控app

辰域智控app

系统工具 下载
网医联盟app

网医联盟app

运动健身 下载
汇丰汇选App

汇丰汇选App

金融理财 下载