文章详情

  • 游戏榜单
  • 软件榜单
关闭导航
热搜榜
热门下载
热门标签
php爱好者> php文档>POJ 2051 Argus 解题报告

POJ 2051 Argus 解题报告

时间:2010-04-02  来源:MC_ACM

POJ 2051 Argus 解题报告

Problem: 2051User: yaoman3

Memory: 276KTime: 94MS

Language: C++Result: Accepted

一、问题描述

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes."
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."


We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period


Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#".

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200

Register 2005 300

#

5

Sample Output

2004

2005

2004

2004

2005

题目大意

二、解题思路

struct Reg

{

       int  t;//下一次输出的时间

       int  num;//Q_num

       int  p;//Period

       };

       首先设Reg数据的值为count(代码中设为t),Reg[count]中所有t的值初始化为p的值,在Reg[count]数组中寻找最小的Reg[i].t,输出此t值,然后t+=p。如此循环直到把前K个t值全部找出。

 

三、代码

 

#include<iostream>
#include<string>
using namespace std;
const int maxn = 1000;
struct record
{
    int num,t,p;
};
int main()
{
    record a[maxn+1];
    string s;
    int i,j,t,k,min,tmp;
    cin>>s; t = 0;
    while (s!="#")
    {
        cin>>a[t].num>>a[t].p;
        a[t].t = a[t].p; t++;
        cin>>s;
    }
    cin>>k;
    for (i=0;i<k;i++)
    {
        min = 0;
        for (j=0;j<t;j++)
        {
            if ((min==0)||(a[j].t<min)||((a[j].t==min)&&(a[j].num<a[tmp].num))) { min = a[j].t; tmp = j; }
        }
        cout<<a[tmp].num<<endl;
        a[tmp].t += a[tmp].p;
    }
}


相关阅读 更多 +
排行榜 更多 +
辰域智控app

辰域智控app

系统工具 下载
网医联盟app

网医联盟app

运动健身 下载
汇丰汇选App

汇丰汇选App

金融理财 下载